+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    Senior Member
    Join Date
    May 2012
    Posts
    111

    Possible Bug - Bulk Change Permissions

    This is for Version 3.4.7.

    In the 'View Asset List', the user selects a group of bulk imported images. She then selects 'Change Permissions' from the 'Batch Actions' menu.

    For 'Groups' she selects 'A'
    For 'Internal' she selects 'N'
    For 'External' she selects 'H'

    Then she selects 'Internal' as the Primary Group and clicks 'Update Assets'.

    From there she chooses to do a template catalog (no template used) and the files now show 'Internal' and 'External' both showing as 'N'. External looses the 'H' attribute.

    She is able to make the changes individually when cataloging, but the batch change isn't holding.

  2. #2
    We cannot reproduce this, when we batch update permissions and then catalogue, the permissions are as per the batch update.

    Can you do this:

    1. Post a screengrab (or use the file sending feature for commercial users, if you prefer) of the batch permissions settings
    2. Rather than cataloguing, use the edit asset option just to see if the permissions are set
    3. Test any differences between recently uploaded files in the same session and those uploaded in a different session (i.e. upload, log out, login and then try this).

    When you say template catalogue, are multiple assets being selected for cataloguing, or one at a time?

    Let us know on these points and we will see if we can get to the bottom of the problem and advise on next steps.

  3. #3
    Senior Member
    Join Date
    May 2012
    Posts
    111
    1. I'm going to plead ignorance here. I don't know where the "batch update permissions" settings are located. I can tell you that there has not been a problem making other batch changes.

    2. The permissions will set if the files are individually edited. We only experience the issue when we attempt to do a bulk edit.

    3. This has happened over multiple days and logins.

    Template catalogue - Multiple assets are being selected for cataloging.

  4. #4
    1. This is what you use to set the permissions as a batch on all your assets, i.e. the choices you make prior to issuing the batch update, we need to see that.

    2 & template. Is the first operation setting the permissions for all your assets in the catalogue set? In other words, are you actually getting a template (for permissions only) even though it was not asked for?

  5. #5
    Senior Member
    Join Date
    May 2012
    Posts
    111
    1. I believe that was answered in the original email:
    In the 'View Asset List', the user selects a group of bulk imported images. She then selects 'Change Permissions' from the 'Batch Actions' menu.

    For 'Groups' she selects 'A'
    For 'Internal' she selects 'N'
    For 'External' she selects 'H'

    Then she selects 'Internal' as the Primary Group and clicks 'Update Assets'.
    2. We are not using any template when we process via the template catalog. We select "Don't use templates".

  6. #6
    Senior Member
    Join Date
    May 2012
    Posts
    111
    Looks like a response I made to this never posted. Trying again:

    1.
    For 'Groups' she selects 'A'
    For 'Internal' she selects 'N'
    For 'External' she selects 'H'

    2. No template is being used. We make batch changes then edit the individual files, we do not use templates at all.

  7. #7
    (1) Can we see a screengrab, as per the original request.

    (2) It's not whether the user employed a template or did not, it's whether multiple assets were selected when editing from catalogue step 1. This does not template catalogue, but does show next/previous buttons at the bottom of the asset catalogue step 2 page.

    We cannot reproduce this fault, so we need more detailed information to see what the differences are between what we do and what your colleague is doing in order that we can try to reproduce it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts